Jump to content

>> Our 360 Cameras Comparison <<

Latest Posts

Vuze Customer Service issues
Views: 11   replies: 0
Last Reply: KToghia (Yesterday, 08:24 PM)
I ordered my camera in April 6th.  The site promised delivery in May.   I contacted support the 1st of May to try and get a more exact delivery timeframe for a production I wanted to use the camera on, and they told via email that my...
Xiaomi Mijia Sphere 360 camera reviews
Views: 256   replies: 2
Last Reply: brendancavan (Yesterday, 12:58 AM)
What do you think about new 360 camera from Xiaomi? If Xiaomi Mija will be so good as Xiaomi Yi 4k, will be great. https://ww...
Xiaomi Mijia Sphere monopod, tripod
Views: 202   replies: 1
Last Reply: brendancavan (Yesterday, 12:43 AM)
Hi Conorr,I've recently purchased the mijia sphere 360 camera and found that a regular selfie stick with a tripod attached to the bottom can be used as a practical and portable tripod for the camera.The selfie stick must have a 1/...
Fish Eye Lense View Curvature
Views: 17   replies: 0
Last Reply: LT (May 24 2017 09:08 PM)
Does anyone know of a way to remove the curvature when you view your photos? I know you can change from the default fish eye lense view to the perspective view but in doing so the quality suffers as the picture gets zoomed in and becomes grainy...
Jumpy video after stitching 360
Views: 30   replies: 0
Last Reply: lseltzer (May 23 2017 04:55 AM)
Just got the new 2017 model from Korea. So far, it's very cool! BUT, if there's an 'active' scene along the stitching lines of the two lenses, the entire video seems to..pulse or jump up and down. It's very distracting. I've turned off all hard...

Recent Topics


Cant connect through Apple software (SnapBridge)

5 replies to this topic

#1 Oziris



  • Members
  • Pip
  • 1 posts

Posted 25 October 2016 - 02:09 PM


Got the camera today and tried to connect through SnapBridge.

Using MacOS 10.12 Sierra, iOS 10.1, downloaded and updated latest firmware.

When trying to connect from SnapBridge, I get an error message and it disconnects the pairing. 

Can operate the camera through the iOS remote.

Documentation is lacking.

Did anyone managed to operate the device with iOS 10.1?


#2 Guest_JP_*

  • Guests

Posted 26 October 2016 - 09:40 AM

Make sure you are using the SnapBridge 170/360 app, which is different from the normal SnapBridge app.  I made this mistake but when I used the 170/360 version of the app it worked fine.  

By the way, the wifi password is NikonKeyMission which you will need once you have the bluetooth connected.  Nikon doesn't include any info on the wifi password in their documentation, which is crazy as you need it to be able to use the app properly.  Also, the app is not great both in features and ease of use.

#3 Guest_DJO_*

  • Guests

Posted 27 October 2016 - 05:47 PM

Super frustrated with this camera. Just sold my Theta S to get this. Regretting it right about now. I have been looking at other people's sample pics.......stitching looks terrible.

#4 lunadude


    Advanced Member

  • Members
  • PipPipPip
  • 132 posts

Posted 28 October 2016 - 02:01 AM

Super frustrated with this camera. Just sold my Theta S to get this. Regretting it right about now. I have been looking at other people's sample pics.......stitching looks terrible.


Are there other stitching options?

#5 dzeek



  • Members
  • Pip
  • 4 posts

Posted 02 November 2016 - 11:48 PM

Are there other stitching options?


No, its done by the camera.

#6 harris



  • Members
  • Pip
  • 8 posts
  • LocationAtlanta

Posted 03 November 2016 - 01:09 AM

Snapbridge 170/360 different from the Snapbridge 360/170 ?
I am a little frustrated with the app as well. It's like paying Nintendo when you have a PS4

Reply to this topic


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users